Вопрос по информатике:
Написать программу для Паскаль через оператор Case.
Для целого числа K от 1 до 99 напечаать фразу "мне K лет", учитывая при этом что при вводе некоторых значений K слово "лет" надо заменить на слово "год" или "года".
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 25.01.2017 04:11
- Информатика
- remove_red_eye 6657
- thumb_up 43
Ответы и объяснения 1
Program p1;
Var a:integer;
Begin
Write('Введите возраст: ');
Readln(a);
Case a of
11..14:Write('Мне ',a,' лет');
else
Case a mod 10 of
1:Write('Мне ',a,' год');
2..4:Write('Мне ',a,' года');
else Write('Мне ',a,' лет');
End;
End;
End.
- 26.01.2017 05:56
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.