Вопрос по информатике:
СРОЧНО !!! 40 БАЛЛОВ .В ПАСКАЛЕ.
напишите программу, которая вводит натуральное число n и выводит на экран все натуральные числа , не превосходящие n и делящиеся на каждую из своих цифр.
- 04.08.2018 12:38
- Информатика
- remove_red_eye 6599
- thumb_up 43
Ответы и объяснения 1
Программа: Var number, i, dv, md : integer; flag : boolean; Begin readln(number); For i := 1 To number Do Begin flag := true; dv := i; While dv > 0 Do Begin md := dv Mod 10; dv := dv Div 10; If (md = 0) Or (md = 1) Then Continue; If i Mod md = 0 Then Begin flag := false; break; End End; If flag Then write(i, ' '); End; End.
- 05.08.2018 00:56
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.