Вопрос по информатике:
Сколько четырехзначных чисел, у которых сумма первой и третьей цифр равны сумме второй и четвертой. Напишите программу, которая позволит вывести все такие числа.
в паскале
- 02.05.2018 00:53
- Информатика
- remove_red_eye 7985
- thumb_up 16
Ответы и объяснения 1
Var a,b,c,d,e:integer;
begin
for a:=1000 to 9999 do begin
e:=a;
b:= e mod 10;
e:= e div 10;
c:= e mod 10;
e:= e div 10;
d:= e mod 10;
e:= e div 10;
if (b+d)=(c+e) then writeln(a);
end;
end.
- 03.05.2018 23:45
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.