Вопрос по информатике:
1.8. Составить программу, которая выдавала бы сообщение ‘ true ‘, если последовательность из N целых чисел, вводимых с клавиатуры, является возрастающей
//////реализовать с помощью 3-х циклов: while, repeat, for)
- 12.05.2018 09:27
- Информатика
- remove_red_eye 18162
- thumb_up 37
Ответы и объяснения 1
Это реализовано с помощью цикла for:
Program p1;
Var a1,a2,k,i:integer;
Begin
Write('Введите число: ');
Readln(a1);
For i:=0 to 1 do
Begin
Write('Введите число: ');
Readln(a2);
if a2>a1 then
k:=k+1;
a1:=a2;
End;
if k=2 then
Writeln('Эта последовательность является возрастающей') else
Writeln('Эта последовательность не является возрастающей');
End.
Это реализовано с помощью цикла while:
Program p2;
Var a1,a2,k,i:integer;
Begin
Write('Введите число: ');
Readln(a1);
While i2 do
Begin
Write('Введите число: ');
Readln(a2);
if a2>a1 then
k:=k+1;
a1:=a2;
i:=i+1;
End;
if k=2 then Writeln('Эта последовательность является возрастающей') else Writeln('Эта последовательность не является возрастающей');
End.
Это реализовано с помощью цикла repeat:
Program p3;
Var a1,a2,k,i:integer;
Begin
Write('Введите число: ');
Readln(a1);
repeat
Begin
i:=i+1;
Write('Введите число: ');
Readln(a2);
if a2>a1 then
k:=k+1;
a1:=a2;
End;
until i=2;
if k=2 then
Writeln('Эта последовательность является возрастающей') else
Writeln('Эта последовательность не является возрастающей');
End.
- 13.05.2018 19:06
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.