Вопрос по информатике:
Напишите программу поиска всех четырёхзначных чисел, у которых все четыре цифры различны.
- 26.09.2018 13:53
- Информатика
- remove_red_eye 7207
- thumb_up 15
Ответы и объяснения 1
Var i,a,b,c,d,temp:integer;
begin
for i:=1000 to 9999 do
begin
temp:=i
a:=temp div 1000;
temp:= temp mod 1000;
b:=temp div 100;
temp:= temp mod 100;
c:=temp div 10;
d:= temp mod 10;
if (ab)and(ac)and(ad)and(bc)and(bd)and(cd) then writeln(i);
end;
end.
- 27.09.2018 15:57
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.