Вопрос по информатике:
Программа в паскаль
Написать программу, которая упорядочивает цифры в заданном пятизначном числе по убыванию.
- 19.04.2015 11:12
- Информатика
- remove_red_eye 18061
- thumb_up 31
Ответы и объяснения 1
//Написать программу, которая упорядочивает цифры в заданном пятизначном числе по убыванию.
var a:array[1..5] of integer;
x,i,j:integer;
begin
Writeln('Введите пятизначное число');
Readln (x);
while (x99999) do // проверка числа на "пятизначность"
begin
writeln ('Вы ввели не пятизначное число попробуйте еще раз');
readln (x);
end;
for i:=1 to 5 do //раскладываем число на отдельные цифры
begin
a[i]:=x mod 10;
x:=x div 10;
end;
for j:=1 to 4 do //сортировка пузырьком
begin
for i:=1 to 4-j do
begin
if a[i]>a[i+1] then
begin
x:=a[i];
a[i]:=a[i+1];
a[i+1]:=x;
end;
end;
end;
for j:=1 to 5 do write (a[j]);//вывод результата
end.
- 20.04.2015 01:40
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.