Вопрос по информатике:
«A»: Напишите программу, которая получает два целых числа A и B (0 < A < B) и выводит квадраты всех натуральных чисел в интервале от A до B.( Через цикл WHILE!!!!)
Пример:
Введите два целых числа:
10 12
10*10=100
11*11=121
12*12=144
- 20.06.2018 22:03
- Информатика
- remove_red_eye 18065
- thumb_up 49
Ответы и объяснения 2
//PascalABC.NET версия 3.3.1590 от 03.12.2017
//Если программа не запускается, то обновите версию
var
A, B: integer;
begin
readln(A, B);
// Assert((A > 0) and (A < B), 'не верные параметры'); //проверка на дурака если надо
while A <= B do
begin
writeln('Квадрат числа ', A, ' = ', A * A);
A := A + 1;
end;
end.
- 21.06.2018 19:46
- thumb_up 39
Var a, b: integer;
begin
repeat
writeln ('Введите два целых числа:');
readln (a,b);
if (ab) then writeln ('Ошибка')
until (a>0) and (b>a);
while a<=b do begin
writeln (a,'*',a,'=',a*a);
a:=a+1;
end;
end.
- 22.06.2018 07:38
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.