Вопрос по информатике:
Написать программу в Pascal
числа a,b и c вводятся с клавиатуры.найти max(a,a+b)+max(a,b+c)/1+max(a+b*c,1,5)
- 23.06.2017 01:14
- Информатика
- remove_red_eye 2671
- thumb_up 49
Ответы и объяснения 2
Уверен, что формула в условии написана неверно, но уж как написано...
var
a,b,c:real;
begin
Write('Введите a,b,c: '); Read(a,b,c);
Writeln('Результат: ',max(a,a+b)+max(a,b+c)/1+max(max(a+b*c,1),5))
end.
Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 31
А вот так, на мой взгляд, должно быть:
var
a,b,c:real;
begin
Write('Введите a,b,c: '); Read(a,b,c);
Writeln('Результат: ',(max(a,a+b)+max(a,b+c))/(1+max(a+b*c,1.5)))
end.
Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 0.6
- 24.06.2017 06:59
- thumb_up 29
Function max (var first,second:real): real;
begin
if first > second then max:=first else max:= second;
end;
var a,b,c,y : real;
begin
writeln('Ведите a,b,c через пробел и нажмите Enter: ');
read(a,b,c);
y:= max(a,a+b)+max(a,b+c)/1+max(a+b*c,1.5);
writeln('Ответ: ',y);
end.
- 25.06.2017 02:31
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.