Вопрос по информатике:
Составьте программу подсчёта числа различных элементов одномерного массива A(Q),не принадлежащих диапозону чисел [R,P]
Желательно с блок схемой
Пожалуйста очень надо
- 25.08.2018 19:43
- Информатика
- remove_red_eye 4536
- thumb_up 33
Ответы и объяснения 1
Var
a:array[1..20] of integer;
i,r,p,q,s:integer;
begin
s:=0;
writeln('vvedite kolichestvo elementov massiva-Q');
readln(q);
writeln('vvedite R');
readln(r);
writeln('vvedite P');
readln(p);
if (p
writeln('neverniy otrezok [R,P]');
exit;
end else
for i:=1 to q do
begin
writeln('vvedite ',i,'-y element massiva');
readln(a[i]);
if (a[i]>=r) and (a[i]<=p) then s:=s+1;
end;
writeln('kollichestvo chisel',p,' =',s);
readln;
end.
- 26.08.2018 19:27
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.