Вопрос по информатике:
1. Построить и записать в виде программы алгоритм вычисления суммы квадратов десяти произвольных чисел, вводимых с клавиатуры в процессе выполнения программы.
2. Вводятся 15 чисел. Определить, сколько среди целых чисел.
3. Вывести все четные числа начиная с числа N и до числа M. Числа N и M задает пользователь.
4. Составить программу, печатающую все делители целого числа в порядке возрастания
- 11.09.2017 00:24
- Информатика
- remove_red_eye 11787
- thumb_up 18
Ответы и объяснения 1
На паскале.
1)
var i, n, sum : integer;
begin
sum := 0;
for i := 1 to 10 do
begin
readln(n);
sum := sum + n * n;
end;
writeln(sum);
end.
2)
var i, sum : integer;
n : real;
begin
sum := 0;
for i := 1 to 15 do
begin
readln(n);
if n = trunc(n) then sum := sum + 1;
end;
writeln(sum);
end.
3) var n, m, i : integer;
begin
readln(n, m);
for i := n to m do
if i mod 2 = 0 then writeln(i);
end.
4) var n, i : integer;
begin
readln(n);
for i := 1 to n do
if n mod i = 0 then writeln(i);
end.
- 12.09.2017 04:30
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.