Вопрос по информатике:
Помогите составить задачу, которую можно решить с помощью цикла предусловия и соответственно написать программу в паскале.
- 27.09.2017 02:27
- Информатика
- remove_red_eye 1499
- thumb_up 29
Ответы и объяснения 1
Написать программу, которая выводит на экран сумму ряда
пусть a – числитель;b – знаменатель;da и db – шаг для числителя и знаменателя;n - для смены знака;
Программа:
const
da= -18; {927-945}
db= 24; {33-9}
var a,b,n: integer;
s: real;
begin
s:=0; n:=1; a:=945;b:=9;
while a>=27 do
begin
s:=s+a/b*n; {подсчет суммы}
a:=a+da;
b:=b+db;
n:= -1*n; {изменение знака}
end;
writeln('s=',s:4:2);
end.
- 28.09.2017 00:24
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.