Вопрос по информатике:
Написать программу на Паскале,которая выведет на экран те строки из текстового файла, которые являются палиндромами. Имя файла вводить с клавиатуры.
- 20.09.2017 18:48
- Информатика
- remove_red_eye 13951
- thumb_up 36
Ответы и объяснения 1
Program proga_25_3;
var
A: text;
s,p : string;
i:integer;
f:boolean;
begin
write('Введите имя и путь к файлу ');
read(p);
assign(A, p);
reset(A);
while not eof(A) do
begin
readln(A,s);
for i:=1 to length(s) div 2 do
if s[i]=s[length(s)-i+1] then
f:=true
else
begin
f:=false;
break;
end;
if f then
writeln (S);
end;
close(A);
end.
- 21.09.2017 08:45
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.