Вопрос по информатике:
Дано действительное число Х. Напишите программу для вычисления:
Числа Х, округлённого до ближайшего целого
Числа Х без дробных цифр
- 09.09.2017 08:29
- Информатика
- remove_red_eye 12053
- thumb_up 35
Ответы и объяснения 1
В Паскале есть функция Round, которая использует следующий "стандартный" алгоритм округления:
Если число положительное, то при величине его дробной части меньше 0.5, она просто отбрасывается, если больше - отбрасывается и к числу прибавляется единица. Если число отрицательное, то при абсолютной величине его дробной части меньше 0.5, она просто отбрасывается, если больше - из числа вычитается единица.
А функция Trunc возвращает целую часть числа.
var
p:real;
begin
Write('Введите число: '); Read(p);
Writeln('Округленное значение: ',Round(p),', целая часть: ',Trunc(p))
end.
Тестовое решение:
Введите число: -12.74
Округленное значение: -13, целая часть: -12
Введите число: 12.93
Округленное значение: 13, целая часть: 12
Введите число: 9.4323
Округленное значение: 9, целая часть: 9
- 01.01.1970 00:00
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.