Вопрос по информатике:
Написать программу,которая в одномерном массиве из 15 элементов подсчитывает количество элементов равных среднеарифметическому
- 20.11.2015 03:03
- Информатика
- remove_red_eye 2504
- thumb_up 26
Ответы и объяснения 1
Uses crt;
const
n=15;
var
a:array[1..n]of real;
i,k:integer;
s:real;
begin
for i:=1 to n do
begin
readln(a[i]);
s:=s+a[i];
end;
s:=s/n;
writeln;
clrscr;
for i:=1 to n do
begin
write(a[i]:6:2);
if a[i]=s then
inc(k);
end;
writeln;
if k0 then
writeln('k: ',k)
else writeln('Нет равных')
end.
- 21.11.2015 23:48
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.