Вопрос по информатике:
Написать программу. Даны 2 числа a и b. Найти среднее арифметическое всех чисел кратных 3 из интервала [a,b].
- 13.08.2015 09:35
- Информатика
- remove_red_eye 10255
- thumb_up 23
Ответы и объяснения 1
var
i, j, a, b: integer;
s: real;
begin
write('Введите a: '); readln(a);
write('Введите b: '); readln(b);
for i := a to b do
if (i mod 3) = 0 then
begin
s := s + i;
inc(j);
end;
s := s / j;
writeln('Ответ: ', s);
end.
- 14.08.2015 12:11
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.