Вопрос по информатике:
Помогите пожалуйста , программа не сложная , но я совсем не умею программировать !!! Написать программу, которая выводит все слова, содержащие букву 'a'.
- 21.09.2017 02:03
- Информатика
- remove_red_eye 16047
- thumb_up 10
Ответы и объяснения 1
Я б не сказал что програма не сложная
var s:string;
i,k1,k2,w:byte;
word,a:boolean;
begin
readln(s);
k1:=1;
word:=true;
a:=false;
s[length(s)+1]:=' ';
for i:=1 to length(s)+1 do
begin
if i=length(s) then begin k2:=length(s); word:=false; end
else if (s[i]=' ') and (word=true) then begin k2:=i; word:=false; end
else if s[i]=' ' then begin k1:=i; word:=true; end;
if s[i]='a' then a:=true;
if (a=true) and (word=false) then
begin a:=false;
for w:=k1 to k2 do
write(s[w]);
write(' ');
end;
end;
writeln;
end.
- 22.09.2017 19:06
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.