Вопрос по информатике:
Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одну строчку все элементы построенного массива, разделив их пробелами.
Примеры
входные данные
6
1 2 3 4 5 6
выходные данные
1 4
- 21.02.2018 14:55
- Информатика
- remove_red_eye 13427
- thumb_up 37
Ответы и объяснения 1
Program a;
var i,n,c: integer;
mas1,mas2 : array[1..10000] of integer;
begin c:=1;
write('размер массива = ');
read (n);
writeln('элементы массива: ');
for i:=1 to n do begin
read (n);
if (n>0) and (n<=10000) then begin
mas1[c]:=n;
inc(c);
end;
end;
n:=1;
writeln('Выходные данные: ');
i:=1;
while i<=(c-1) do begin
mas2[n]:=mas1[i];
inc(n);
i := i + 3;
end;
for i:=1 to n-1 do
write (mas2[i],' ');
end.
- 23.02.2018 00:04
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.