Вопрос по информатике:
Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших).
- 10.07.2018 07:01
- Информатика
- remove_red_eye 12029
- thumb_up 29
Ответы и объяснения 1
Var
n,k:integer;
begin
Write('Укажите число и номер инвертируемого бита: ');
Read(n,k);
Writeln('Результат: ',n xor (1 shl k))
end.
Тестовое решение:
Укажите число и номер инвертируемого бита: 573 4
Результат: 557
- 11.07.2018 02:42
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.