Вопрос по информатике:
.Помогите составить программу на паскале:)
Для десяти чисел введенных с клавиатуры все отрицательные сложить а положительные умножить
- 06.12.2017 23:34
- Информатика
- remove_red_eye 12991
- thumb_up 26
Ответы и объяснения 2
Var a,b,c,d:integer;
beginwriteln('введите десять чисел');
readln(a);
b:=1;
d:=0;
for c:=2 to 10 do
begin
readln(a);
if (a > 0) then b:=b*a;
if (a < 0) then d:=d+a;
end;
writeln('положительные ',b);
writeln('отрицательные ',d)
end.
- 07.12.2017 18:35
- thumb_up 45
Const
N = 10;
var
x, i, minus, plus:integer;
begin
plus:=-1;
minus:=0;
for i:=1 to N do
begin
readln(x);
if x<0 then
minus:=minus+x;
if x>0 then
if plus = -1 then
plus:=x
else
plus:=plus*x;
end;
writeln('Сумма отрицательных чисел: ', minus);
if plus = -1 then
writeln('Положительных чисел нет')
else
writeln('Произведение положительных чисел:', plus);
end.
- 08.12.2017 11:31
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.