Вопрос по информатике:
Напишите программу,которая в последовательности натуральных чисел определяет количество нечетных чисел,кратных 5. Программа получает на вход количество чисел в последовательности,а затем сами числа. В последовательности всегда имеется число,кратное 4. Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число -количество чисел, кратных 4
- 20.09.2018 13:33
- Информатика
- remove_red_eye 12883
- thumb_up 15
Ответы и объяснения 1
1)Program pr;
uses crt;
Var a,k,k1:integer;
Begin
Writeln('Введите a');
readln(a);
k1:=1;
k:=0;
While (a0) and (k1<1000) do
Begin
if (a<0) and (a mod 2=0) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln('k=',k);
readln;
end. 2)
Program pr;
uses crt;
Var a,k,k1:integer;
Begin
Writeln('Введите a');
readln(a);
k1:=1;
k:=0;
While (a0) and (k1<1000) do
Begin
if (a>0) and (a mod 20) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln('k=',k);
readln;
end.
- 21.09.2018 18:33
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.