Вопрос по информатике:
Срочно! создать программу!
тема "организация подпрограмм через функцию"
задача
дан параллепипед с измерениями а,b, c. Составить программу для нахождения площади полной поверхности, используя подпрограмму нахождения площади прямоугольника.
- 23.12.2017 09:19
- Информатика
- remove_red_eye 7842
- thumb_up 14
Ответы и объяснения 1
Вычисление производим по формуле
function Sp(x,y:real):real;
begin
Sp:=x*y
end;
var
a,b,c,S:real;
begin
Write('Введите размеры сторон a,b,c: ');
Read(a,b,c);
S:=2*(Sp(a,b)+Sp(a,c)+Sp(b,c));
Writeln('Площадь поверхности равна ',S)
end.
Тестовое решение:
Введите размеры сторон a,b,c: 2.5 3.15 4
Площадь поверхности равна 60.95
- 24.12.2017 02:12
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.