Вопрос по информатике:
Написать программу, которая запрашивает массив размерности N и выводит на экран сам массив, а также наибольший и наименьший элементы массива. Протестировать программу на массивах размерностью 5 и 10 элементов.
- 06.07.2018 00:07
- Информатика
- remove_red_eye 6981
- thumb_up 24
Ответы и объяснения 1
Var a:array [1..100] of integer;
max, min, n, i:integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to 10 do
write(a[i],' ');
max:=-maxint;
min:=maxint;
for i:=1 to n do begin
if a[i]>max then max:=a[i];
if a[i]
writeln('Наибольший элемент: ',max);
writeln('Наименьший элемент: ',min)
end.
- 07.07.2018 21:01
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.