Вопрос по информатике:
Задача 1. Составьте программу задания массива вещественных чисел yj? состоящего из 79 элементов.
Задача 2. Найдите произведение всех элементов массива из задачи 1.
Задача 3. Составьте программу для решения следующей задачи: задан массив N, состоящий из х чисел. Разделите каждый элемент массива пополам и напечатайте результат. Элементы вводятся с клавиатуры.
Задача 4. В заданном одновременном массиве, состоящем из х целых чисел, подсчитать количество элементов меньших -3.
Задача 5. В одномерном массиве заданном произвольно найдите сумму только тех элементов, которые состоят на нечетных местах.
- 13.10.2017 11:21
- Информатика
- remove_red_eye 4091
- thumb_up 22
Ответы и объяснения 1
Язык c++
Первая задача и вторая в одном проекте.
#include
#include // включает srand() и rand()
#include // содержит time
int main(){
float mas[79];
double mult = 1;
srand(time(NULL));// при каждом запуске будут новые случайные числа
for (int i=0; i<79; i++) mas[i] = 0.1*rand();//заполнение массива случайными числами
// Задача 2: произведение этих элементов:
for (int i=0; i<79; i++) mult*=mas[i];
std::cout << "mult = " << mult << std::endl;
system("pause");
return 0;
}
Третья:
#include
#define x 3 //определяем максимальный размер массива, сейчас 3
using namespace std;
int main(){ float N[x];
int i;
for (i=0; i
}
cout << "-------------------" << endl;
for (i=0; i
system("pause");
}
Четвертая:
#include
#define N 3 //определяем максимальный размер массива, сейчас 3
using namespace std;
int main(){
int mas[N], i, j;
for (i=0; i
cin >> mas[i];
}
cout << "-------------------" << endl;
for (i=0, j=0; i
cout << "summa mas[i] < -3 = " << j << endl;
system("pause");
}
Пятая:
#include
#include // включает srand() и rand()#include // содержит time
#define N 5
int main(){
int mas[N], sum=0;
srand(time(NULL));// при каждом запуске будут новые случайные числа for (int i=0; i
if (i%2) sum+=mas[i];
}
std::cout<<"sum= " << sum << std::endl;
system("pause");
}
- 14.10.2017 12:53
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.