Вопрос по информатике:
Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 ( F 1 = F 2 = 1 ), а каждое следующее равно сумму двух предыдущих: F n = F n - 1
+ F n - 2 . Напишите программу, которая вводит натуральное число N и выводит на экран первые N числа Фибаначчи
- 27.03.2018 04:16
- Информатика
- remove_red_eye 6733
- thumb_up 39
Ответы и объяснения 1
1 var a, b, c, n, i: integer;
2
3 begin
4 writeln('Vvedite N');
5 readln(n);
6 a :=1; b :=1;
7 for i := 3 to n do begin
8 c := a + b;
9 a := b;
10 b :=c;
11 end;
12 writeln(c);
13 end.
- 28.03.2018 01:36
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.