Вопрос по информатике:
Помогите пожалуйста по языку паскаля, завтра уже сдать надо.
1) Напишите программу, которая выводит код введенного пользователем символа.
Программа должна завершать свою работу в результате ввода, например точки.
2)Напишите программу, которая выводит на экран первую часть таблицы кодировки символов (от 0 до 127). Таблица должна состоять из восьми колонок и шестнадцати строк. В первой колонке должны быть символы с кодом от 0 до 15, во второй от 16 до 31 и т.д.
- 01.08.2018 14:36
- Информатика
- remove_red_eye 2946
- thumb_up 9
Ответы и объяснения 1
1 задача:
program znan1;
uses crt;
var a:char;
begin
clrscr;
readln(a);
while a'.' do
begin
writeln(ord(a));
readln(a);
end;
end.
2 задача:
program znan2;
uses crt;
var i,j:integer;
begin
for i:=1 to 16 do
begin
for j:=1 to 8 do
begin
write((i*j-1):5,'-',chr(i*j-1));
end;
writeln;
end;
readln;
end.
- 02.08.2018 04:59
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.