Вопрос по информатике:
Помогите пожалуйста с языком паскаля, срочно надо.
1) написать программу, которая удаляет из строки заданное количество символов.
2) написать программу, которая выставляет в строку подстроку.
3) написать программу подсчитывающую количество знаков $ в вводимой строке.
- 27.09.2016 17:59
- Информатика
- remove_red_eye 8122
- thumb_up 24
Ответы и объяснения 1
Var strok: string; n,k: integer;
begin
writeln('введите строку');
readln(strok);
writeln('с какого по счёту символа начать удаление?');
readln(n);
writeln('сколько символов удалить?');
readln(k);
delete(strok, n, k);
writeln(strok);
end.
это первая
var strok,strok2: string;
n: integer;
begin
writeln('введите строку');
readln(strok);
writeln('с какого символа по счёту вставить строку?');
readln(n);
writeln('какую строку вставить?');
readln(strok2);
insert(strok2 ,strok, n);
writeln(strok);
end.
это вторая, а третья в коментах, иначе не влезет
- 28.09.2016 22:05
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.