Вопрос по информатике:
В текстовом файле хранятся координаты n точек на плоскости.
Составить программу для:
подсчета количества точек, попадающих в заданную область;
формирования массива из координат точек, попадающих в заданную область;
полученный массив дописать в созданный ранее текстовый файл.
(на паскале)
- 25.02.2018 03:08
- Информатика
- remove_red_eye 15800
- thumb_up 41
Ответы и объяснения 1
Запишем каноническое уравнение эллипса:
Теперь составим критерий принадлежности точки А(x,y) заштрихованной области:
Вспомогательная программа, создающая файл:
const
n=50;
var
i:integer;
f:Text;
begin
Assign(f,'xy.txt');
Rewrite(f);
Randomize;
for i:=1 to n do Writeln(f,6*Random-3,' ',5*Random-2.5);
Close(f);
end.
Программа, выполняющая задание:
const
n=50;
var
x,y:real;
i,k:integer;
a:array[1..n,1..2] of real;
f:Text;
begin
Assign(f,'xy.txt');
Reset(f);
k:=0;
Writeln('Отобранные точки');
while not Eof(f) do begin
Readln(f,x,y);
if (sqr(x)=1) then
begin
Writeln(x,' ',y);
Inc(k); a[k,1]:=x; a[k,2]:=y
end
end;
Writeln('Количество точек = ',k);
Close(f);
Append(f);
for i:=1 to k do Writeln(f,a[i,1],' ',a[i,2]);
Close(f)
end.
- 26.02.2018 06:11
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.