Вопрос по информатике:
Составить программу в Паскаль:Даны 4 числа,выделить целые части и найти среднее арифметическое этих чисел.
- 23.08.2018 07:48
- Информатика
- remove_red_eye 8204
- thumb_up 27
Ответы и объяснения 1
Var
i:integer;
a,c:real;
begin
c:=0;
Writeln('Введите четыре произвольных числа');
for i:=1 to 4 do
begin
Read(a); c:=c+Int(a)
end;
c:=c/4;
Writeln('Среднее арифметическое равно ',c)
end.
Тестовое решение:
Введите четыре произвольных числа
4.7 5.03 4.12 5
Среднее арифметическое равно 4.5
- 24.08.2018 16:10
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.