Вопрос по информатике:
С клавиатуры вводится строка символов. Составить программу , которая находит номер первого и последнего символа 'к' и заменяет все символы между этими буквами на звездочку .
Сделать алгоритм и программу
- 25.02.2017 20:17
- Информатика
- remove_red_eye 18853
- thumb_up 41
Ответы и объяснения 1
program zwezda;
uses Crt;
var S: string;
i, Len: integer ;
begin
ClrScr;
Write('Ввод строки: '); ReadLn(S);
ClrScr;
WriteLn ('‘Строка: ', S);
WriteLn;
WriteLn ('Первый символ: ', S[1]);
Writeln;
Len:=length(S);
WriteLn('Посдедний символ: ',S[Len]);
WriteLn;
for i:=2 to len -1 do
S[i]:='*';
WriteLn('Результат: ',s);
ReadLn;
end.
- 26.02.2017 00:06
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.