Вопрос по информатике:
Нужно решить 2 задачи по информатике:
1) дан массив B[1..10] составьте программу которая находит количество элементов, которые больше своего соседа слева
2) дан массив B[1..10] составьте программу которая находит количество пар элементов с четным значением
- 16.02.2015 08:05
- Информатика
- remove_red_eye 3759
- thumb_up 50
Ответы и объяснения 1
Вот решение первой задачки:
program Sosed;
uses Crt;
const n = 10;
type Vec = array [1..n] of integer;
var A: Vec;
i, Col: integer;
begin
ClrScr;
Randomize;
WriteLn('Massiv A:');
for i:=1 to n do
begin
A[i]:= 10+random (90);
Write (A[i]:4);
end;
WriteLn;
Col:=0;
for i:=2 to n do
begin
if A[i] Col:=Col+1;
end;
WriteLn;
if Col0 then Writeln('Col =', Col)
else WriteLn('None!');
ReadLn;
end.
- 17.02.2015 00:26
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.