Вопрос по информатике:
Помогите в паскале составить
прогу.если можно на уровне 9го класса
Составить программу для вычисления значения функции на отрезке [a,b] с шагом 1.
- 23.08.2018 09:13
- Информатика
- remove_red_eye 9268
- thumb_up 44
Ответы и объяснения 1
Мы взяли функцию f(x) = sin(x)-2*cos(x).
В процедуру-функцию function можно вставлять любые функции
program func;
uses Crt;
var a, b, x, y:real;
function f(var x:real):real;
begin
f:=sin(x)-2*cos(x);
end;
begin
ClrScr; {Очистка экрана}
Write (' a= '); ReadLn(a);
Write (' b= '); ReadLn(b);
WriteLn;
x:=a;
while x<=b do
begin
y:=f(x);
WriteLn ('y(', x:1:0, ')= ', y:4:2);
x:=x+1;
end;
ReadLn;
end.
- 24.08.2018 21:48
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.