Вопрос по информатике:
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35;35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов; 4) заменить числом 5 элементы, стоящие на четных местах, и числом 0 - элементы, стоящие на нечетных местах, вывести в строку получившийся массив.
- 27.03.2018 10:38
- Информатика
- remove_red_eye 11928
- thumb_up 8
Ответы и объяснения 1
Program t1;
const
j = 18
var
n,j, i, s,s1: integer;
mas: array [1..j] of integer;
begin
randomize;
writeln ('сгенерированный масив: ');
for i := 1 to j do
begin
mas[i] := random (70) - 35;
write (mas[i]);
end;
s:= 0; s1:=0;
for i := 1 to j do
begin
if (i mod 2 =0) then s := s+mas[i]; //сумма четных элементов
if (mas[i] >= 0) then s1 := s1 + mas[i]; //сумма неотрицательных элементов
end;
writeln ('среднее арифметическое четных элементов: ', s/18);
writeln ('сумма неотрицательных элементов: ', s1);
writeln ('массив после замены элементов: ');
for i := 1 to j do
begin
if (i mod 2 =0) then mas[i] := 5 else mas[i] := 0;
write (mas[i]);
end;
end;
end.
- 28.03.2018 16:26
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.