Вопрос по информатике:
Помогите написать программу в Паскале ..... Дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном порядке.
- 13.09.2017 12:28
- Информатика
- remove_red_eye 10104
- thumb_up 17
Ответы и объяснения 1
Var
m,n,n1,n2,n3,n4:integer;
begin
Write('Введите трехзначное натуральное число: ');
Readln(n);
n1:= n mod 10;
n2:= (n mod 100) div 10;
n3:= n div 100;
m:=n1+n2+n3;
Write('сумма цифр: ',m);
Write('среднее арифметическое: ',m/3);
m = 100*n1 + 10*n2 + n3;
Writeln(' в обратном порядке: ',m)
end.
- 14.09.2017 03:39
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.