Вопрос по информатике:
Помогите решить пожалуйста даю 20 баллов!!!
Дано целое число N (0<=N<=9). Написать программу, вычисляющую сумму всех двузначных чисел(в записи которых нет цифры N)
Даны целые числа A и B.Написать программу, подсчитывающую сумму двузначных чисел, у которых либо первая цифра равна A, либо вторая цифра равна B.
Написать программу, определяющую количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N
Все через While
- 16.07.2018 12:17
- Информатика
- remove_red_eye 15689
- thumb_up 8
Ответы и объяснения 1
Program tak;
var a,b,c,N:integer;
begin writeln('введите число N (0<=N<=9) ');
readln(N);
b:=0;
for a:=99 downto 10 do begin
if (N a div 10) and (N a div 10) then
b:=a+b;
end;
writeln(b);
end.
эт первая
program tak2;
var a,b,c,d:integer;
begin writeln('введите два числа ');
readln(a,b);
d:=0;
for c:=99 downto 10 do begin
if (a = c div 10) or (b = c mod 10) then
d:=c+d;
end;
writeln(d);
end.
эт вторая
- 17.07.2018 21:40
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.