Вопрос по информатике:
Написать программу, которая осуществляет вывод одномерного массива, поиск максимального значения и выводит его индекс в этом массиве.
- 12.01.2018 00:22
- Информатика
- remove_red_eye 6539
- thumb_up 40
Ответы и объяснения 1
Var i,imax,amax:integer;
a:array[1..10] of integer;
begin
writeln('Введите числа');
for i:=1 to 10 do
begin
write('a[',i,']= ');
read(a[i]);
end;
a[1]:=amax;
imax:=1;
for i:=1 to 10 do
if amaxbegin
amax:=a[i];
imax:=i;
end;
writeln('Исходный массив');
for i:=1 to 10 do
write(a[i]:4);
writeln;
writeln('Элемент под номером ',imax,' имеет максимальное значение равное ',amax);
end.
- 13.01.2018 14:01
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.