Вопрос по информатике:
Написать программу на языке C/C++, которая принимает на вход:
1. N целочисленных элементов, где N = 5 + (k mod 5). Здесь k=10.
N можно задавать равным конкретному числу прямо
внутри программы.
2. Целое число A (после того, как считали N чисел).
Найдите индекс (порядковый номер) первого числа (из введенных N чисел), равного A.
Если такого числа нет, выведите соотв. сообщение (например, “no number A”).
Написать данную программу с использованием конструкции if, цикла for, ИСПОЛЬЗУЙТЕ
массив. Использование команды goto запрещено. Подсказка: заведите целочисленный
массив, соответствующий вашему варианту задания (т.е числу N), например,
int SavedNumbers[7];
в цикле считывайте очередное целое число, пишите его в массив. После считки всех
чисел и окончания цикла считайте число A. Ещё раз пройдите по массиву и найдите
первое вхождение A, если оно есть.
- 25.08.2017 02:54
- Информатика
- remove_red_eye 8830
- thumb_up 48
Ответы и объяснения 1
#include
int main() {
const int k = 10;
int n = 5 + k % 5;
int savedNumbers[n];
for (int i = 0; i < n; i++) {
scanf("%d", &savedNumbers[i]);
}
int a;
scanf("%d", &a);
for (int i = 0; i < n; i++) {
if (a == savedNumbers[i]) {
printf("First in - %d.", i + 1);
return 0;
}
}
printf("No number A.");
return 0;
}
- 26.08.2017 05:07
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.