Вопрос по информатике:
Помогите ~ Очень нужно
1. Составить программу нахождения площади ромба, если известны стороны и диагонали. (Паскаль. Если не трудно, то можно объяснить, как сделать программу)
2. 16x^4-√x (Паскаль)
16sqr(sqr(x))-(sqrt(x))
- 23.11.2017 16:30
- Информатика
- remove_red_eye 3922
- thumb_up 30
Ответы и объяснения 1
1. Не знаю, как совместить стороны и диагонали в одном решении, сделал нахождение по диагоналям.
var d1, d2, S: real;
begin
write('Введите диагонали d1 и d2');
readln(d1, d2);
if(d1>0) and (d2>0) then
begin
S:=(d1*d2)/2;
writeln('Площадь равна: ', S)
end
else
writeln('Условия неверны!')
end.
Чтобы написать, достаточно знать основы паскаля. Если есть вопросы к какой-либо строке - напиши.
2. 16*sqr(sqr(x))-(sqrt(x))
- 24.11.2017 23:19
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.