Вопрос по информатике:
Составьте программу которая вычисляет сумму натуральных чисел на отрезке ( 5, 10 ) с помощью оператора While
- 07.02.2015 11:31
- Информатика
- remove_red_eye 13296
- thumb_up 32
Ответы и объяснения 2
#include
#include
#include
using namespace std;
int main()
{
setlocale(0,"");
int x_min,x_max;
int Sum;
cout<<"Введите начало отрезка\n";
cin>>x_min;
cout<<"Введите конец отрезка\n";
cin>>x_max;
int temp=x_min;
if(x_min>x_max) //проверяем что бы минимальный элемент не был больше максимального
{
int temp;//буфер
temp=x_min;
x_min=x_max;
x_max=temp;
}
while(x_min<=x_max)
{
Sum+=x_min;
++x_min;
}
cout<<"Сумма натуральных эментов на отрезке ("<
}
Программа вычисляет отрезок любого элемента и делает проверку на правильность ввода
- 09.02.2015 02:22
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.