Вопрос по информатике:
Нужна помощь по информатике. Задача:
Написать программу вычислить произведение из двух наибольших введенных с клавиатуры чисел.( в ПАСКАЛЕ). Проще говоря, у меня есть три числа, я должен ввести их, и два наибольших из них должны перемножаться. Нужно написать программу используя условные операторы. Заранее спасибо.
- 16.03.2017 23:53
- Информатика
- remove_red_eye 2657
- thumb_up 42
Ответы и объяснения 2
Var m: array [1..3] of real;
var i, imin, imax: integer;
var num, pro: real;
begin
imin:=1;
imax:=1;
for i:=1 to 3 do read (m[i]);
for i:=1 to 3 do
begin
if m[i]
end;
num:=m[1]+m[2]+m[3]-m[imin]-m[imax];
pro:=num*m[imax];
write (pro);
end.
- 17.03.2017 11:24
- thumb_up 31
Var
a,b,c:integer;
begin
Write('Введите три целых числа: '); Readln(a,b,c);
if a>b then
if b>c then Writeln(a*b) else Writeln(a*c)
else
if a>c then Writeln(a*b) else Writeln(b*c)
end.
Тестовое решение:
Введите три целых числа: 5 -2 7
35
- 18.03.2017 04:02
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.