Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет. Значение выводить с точностью до десятых.
Нужно написать программу на языке PaskalABC.
Вот что получилось у меня, но пишет, что на 12 строке "Встречено ':=', а ожидался оператор"
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 07.04.2017 00:36
- Информатика
- remove_red_eye 16925
- thumb_up 14
Ответы и объяснения 1
Uses crt;
var
n,s,k: integer;
begin
s:=0;
k:=0;
repeat
readln(n);
if (n0) and (n mod 8 = 0) then
begin
s:=s+n;
inc(k);
end;
until n=0;
if (s0) then
writeln(s/k:0:1)
else writeln('NO');
end.
- 07.04.2017 22:56
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.