Вопрос по информатике:
Составьте программу вычисления значения выражения для данного натурального числа N: 4+8+12+ … +4∙N.(паскаль)
- 07.08.2018 22:08
- Информатика
- remove_red_eye 11552
- thumb_up 25
Ответы и объяснения 1
Вариант первый, обычным циклом.
program easy;
var n,i,k,a:integer;
begin
readln(n);
for i:=1 to n do begin
k+=4; //k=4i
a+=k;
end;
writeln(a);
end.
Вариант второй. Искомую сумму можно представить как
program normal;
var n:integer;
begin
readln(n);
writeln(2*n*(n+1));
end.
- 08.08.2018 22:50
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.