Вопрос по информатике:
Царевна-лягушка съедает ежедневно на 20% комаров больше, чем в предыдущий день, и еще 2 комара. Через сколько дней количество съеденных комаров в день превысит 30, если в первый день было съедено 12 комаров. Воспользовавшись словесным алгоритмом, заполните шаблон блок-схемы и составьте программу для решения задачи.
- 10.06.2018 18:39
- Информатика
- remove_red_eye 8865
- thumb_up 45
Ответы и объяснения 1
var mosquito :integer;
day, sum :integer;
BEGIN
day := 1;
mosquito := 12;
sum := 0;
repeat
mosquito := Trunc(mosquito * 1.2) + 2;
day := day +1;
sum := sum + mosquito;
writeln(' day mosquito sum);
until sum > 100;
writeln(day);
end
- 11.06.2018 07:07
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.