Вопрос по информатике:
Дан массив, состоящий из целых чисел. Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего). Напишите программу, которая определит количество различных чисел в этом массиве.
Входные данные
Сначала задано число N — количество элементов в массиве (1N100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести единственное число - количество различных чисел в массиве.
Примеры
Входные данные
5
1 1 1 1 1
Выходные данные
1
- 07.02.2016 17:18
- Информатика
- remove_red_eye 14790
- thumb_up 16
Ответы и объяснения 1
Program X;
var
mas: array[1..1000000] of longint;
N,i,count:longint;
begin
count:=1;
readln(N);
for i:=1 to N do
read(mas[i]);
if N>1 then
begin
for i:=2 to N do
if mas[i]mas[i-1] then inc(count);
writeln(count)
end
else
writeln(1)
end.
- 08.02.2016 14:05
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.