Вопрос по информатике:
Напишите программу,которая выбирает максимальное и минимальное из пяти введённых чисел.
- 27.07.2018 10:26
- Информатика
- remove_red_eye 6304
- thumb_up 38
Ответы и объяснения 2
Var mas5: array [1..5] of real;
var a: real;
var i, amax, amin: integer;
begin
amax:=1;
amin:=1;
writeln ('Введите числа: ');
for i:=1 to 5 do
begin
read (a);
mas5[i]:=a;
end;
for i:=1 to 5 do
begin
if mas5[i]
end;
writeln;
writeln (mas5[amin], ' ', mas5[amax]);
end.
- 28.07.2018 00:44
- thumb_up 34
Const
n = 5;{ это позволяет в одном месте изменить количество чисел }
type
numeric = real;{ это позволяет в одном месте изменить тип чисел }
var
max, min: numeric;
i: integer;
a: array[1..n] of numeric;
begin
Writeln('Введите ', n, ' произвольных чисел через пробел');
Read(a[1]);
min := a[1]; max := min;
for i := 2 to n do
begin
Read(a[i]);
if max < a[i] then max := a[i]
else
if min > a[i] then min := a[i]
end;
Writeln('Минимальное введенное: ', min, ', максимальное: ', max)
end.
Тестовое решение:
Введите 5 произвольных чисел через пробел
34 157 -84.54 14.843 -13.64
Минимальное введенное: -84.54, максимальное: 157
- 29.07.2018 22:06
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.