Вопрос по информатике:
Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного массива размером 30 элементов, в предположении, что в массиве есть хотя бы 1 отрицательный элемент (Паскаль)
- 22.01.2016 04:17
- Информатика
- remove_red_eye 2160
- thumb_up 46
Ответы и объяснения 1
Var mas30: array [1..30] of integer;
var i, proz: integer;
begin
proz:=1;
for i:=1 to 30 do begin mas30[i]:=-5+random (11); //Заполнение массива
write (mas30[i], ' '); //вывод значений массива
end;
writeln;
for i:=1 to 30 do if mas30[i]<0 then proz:=proz*mas30[i]; //Подсчет произведения отриц элементов
writeln (proz);
end.
- 23.01.2016 20:35
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.