Вопрос по информатике:
Дан массив E(10). Составить программу обработки массива:
1. Положительные элементы массива заменить нулями.
2. Определить число элементов массива равных 5.
3. Найти сумму чисел, неравных 3.
Все это должно быть в одной задаче, решите плиз качественно, даю много баллов.
Ах, да, все это на языке паскаль.
- 24.11.2016 20:57
- Информатика
- remove_red_eye 10854
- thumb_up 43
Ответы и объяснения 1
var sum,c,i,l:integer;
E:array[1..10] of integer;
begin
writeln('Введите числа');
for i:=1 to 10 do begin
read(e[i]);
if e[i]>0 then e[i]:=0;
if e[i]=5 then l:=l+1;
if e[i] 3 then sum:=sum+e[i];
end;
writeln('Полученный массив');
for i:=1 to 10 do
write(e[i]:4);
writeln;
writeln('Сумма чисел, не равных трем равна ',sum);
writeln('Число элементов массива, равных пяти равна ',l);
end.
- 25.11.2016 20:10
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.