Вопрос по информатике:
Написать программу:
Даны длины сторон треугольника a,b,c. Является ли он прямоугольным?
- 08.02.2018 11:57
- Информатика
- remove_red_eye 3999
- thumb_up 25
Ответы и объяснения 1
Var a,b,c,t:real;
begin
readln(a,b,c);
if b>a then begin
t:=a;
a:=b;
b:=t;
end;
if c>a then begin
t:=a;
a:=c;
c:=t;
end;
if (a*a=b*b+c*c) then writeln('Треугольник прямоугольный') else writeln('Треугольник не прямоугольный');
end.
- 09.02.2018 17:34
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.