Вопрос по информатике:
Составьте программу, позволяющую определить, являются ли числа A,B,C, пифагоровыми тройками.Указанные числа A,B,C, являются пифагоровыми тройками, если квадрат одного из чисел равен сумме квадратов двух других.
- 11.11.2017 01:34
- Информатика
- remove_red_eye 7653
- thumb_up 27
Ответы и объяснения 1
Program pifThi;
var
a,b,c:integer;
begin
readln(a,b,c);
if (sqr(a)=sqr(c)+sqr(b)) or
(sqr(b)=sqr(a)+sqr(c)) or
(sqr(c)=sqr(a)+sqr(b)) then write('Yes!')
else write('No!'); readln;
end.
- 12.11.2017 02:58
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.