Вопрос по информатике:
Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива.
- 06.02.2018 13:36
- Информатика
- remove_red_eye 8537
- thumb_up 26
Ответы и объяснения 1
Var n, i, sum: integer;
a: array[1..100] of integer;
average: real;
begin
write('Сколько чисел будет в массиве? ');
readln(n);
sum := 0;
for i := 1 to n do
begin
write('Введите ', i, ' число: ');
readln(a[i]);
sum := sum + a[i];
end;
average := sum/n;
writeln('Среднее арифметическое: ', average);
end.
- 07.02.2018 12:29
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.