Вопрос по информатике:
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
- 14.04.2015 08:55
- Информатика
- remove_red_eye 17406
- thumb_up 15
Ответы и объяснения 1
Var x, otrc, poloz: integer;
begin
repeat
write('Введите число: ');
readln(x);
if x > 0 then inc(poloz);
if x < 0 then inc(otrc);
until x = 0;
writeln('Количество положительных чисел: ', poloz);
writeln('Количество отрицательных чисел: ', otrc);
end.
- 15.04.2015 09:09
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.